Python 问题记录:XXX.whl is not a supported wheel on this platform.

互联网 2021/10/13 22:15:48

因为公司网络限制 无法使用在线安装python 模块 ,于是并想到通过安装.whl 文件的方式, 但是再下载和安装这个模块时 疯了。 首先:官网列有一堆模块,不确定自己的平台应该使用哪个模块。其次:自己下载的几个版本再进行安装的时候皆报错python 环境中输入 import pip._i…

因为公司网络限制 无法使用在线安装python 模块 ,于是并想到通过安装.whl 文件的方式, 但是再下载和安装这个模块时 疯了。

首先:官网列有一堆模块,不确定自己的平台应该使用哪个模块。


其次:自己下载的几个版本再进行安装的时候皆报错

python 环境中输入 import pip._internal.pep425tags;print(pip._internal.pep425tags.get_supported())

可以 其中有一个('cp36', 'cp36m', 'manylinux1_x86_64')意味着如果我要安装python3.6版本的whl,那么我的whl文件中应该是manylinux1_x86_64而不是manylinux2010_x86_64,所以我将文件名改成PyMuPDF-1.16.11-cp36-cp36m-manylinux1_x86_64.whl,然后再进行安装,结果安装成功。

随时随地学软件编程-关注百度小程序和微信小程序
关于找一找教程网

本站文章仅代表作者观点,不代表本站立场,所有文章非营利性免费分享。
本站提供了软件编程、网站开发技术、服务器运维、人工智能等等IT技术文章,希望广大程序员努力学习,让我们用科技改变世界。
[Python 问题记录:XXX.whl is not a supported wheel on this platform.]http://www.zyiz.net/tech/detail-241036.html

上一篇:python之r,w,a

下一篇:np.zeros的问题&&python错误:TypeError: Cannot interpret ‘3‘ as a data type

赞(0)
关注微信小程序
程序员编程王-随时随地学编程

扫描二维码或查找【程序员编程王】

可以随时随地学编程啦!

技术文章导航 更多>
扫一扫关注最新编程教程